Thu, 02 Feb 2023 13:15:34 EST

Information for RPM perl-AppConfig-1.66-1.ru.noarch.rpm

ID5764
Nameperl-AppConfig
Version1.66
Release1.ru
Epoch
Archnoarch
SummaryModule for reading configuration files and parsing command line args
DescriptionAppConfig is a bundle of Perl5 modules for reading configuration files and parsing command line arguments. This is a descendant of, and supercedes the App::Config module. Functionality is extended over the final version of App::Config (1.09) and includes many new features. This module has been developed and in the process, renamed, as part of an effort to unify the various Perl modules for parsing configuration files and command line arguments. AppConfig has a powerful but easy to use module for parsing configuration files. It also has a simple and efficient module for parsing command line arguments. For fully-featured command line parsing, a module is provided for interfacing AppConfig to Johan Vromans' extensive Getopt::Long module. Johan will continue to develop the functionality of this package and its features will automatically become available through AppConfig. All of the modules and features of the AppConfig bundle are easily accessible through the AppConfig.pm module.
Build Time2008-12-22 21:23:23 GMT
Size97558
Payload Hash760a487333f781b13efece69f86323c6
Buildrootcentos5-rutgers-build-70-50
Provides
perl(AppConfig) = 1.66
perl(AppConfig::Args) = 1.65
perl(AppConfig::CGI) = 1.65
perl(AppConfig::File) = 1.65
perl(AppConfig::Getopt) = 1.65
perl(AppConfig::State)
perl(AppConfig::State) = 1.65
perl(AppConfig::Sys) = 1.65
perl-AppConfig = 1.66-1.ru
Requires
perl(AppConfig)
perl(AppConfig::State)
perl(Getopt::Long) >= 2.17
perl(POSIX)
perl(base)
perl(constant)
perl(strict)
perl(warnings)
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(VersionedDependencies) <= 3.0.3-1
Obsoletes No Obsoletes
Conflicts No Conflicts
Files
1 through 22 of 22
Name ascending sort Size
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig4096
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig.pm32517
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/Args.pm7679
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/CGI.pm6927
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/File.pm24082
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/Getopt.pm8261
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/State.pm47129
/usr/lib/perl5/vendor_perl/5.8.8/AppConfig/Sys.pm7982
/usr/share/doc/perl-AppConfig-1.664096
/usr/share/doc/perl-AppConfig-1.66/Changes5856
/usr/share/doc/perl-AppConfig-1.66/LICENSE20217
/usr/share/doc/perl-AppConfig-1.66/MANIFEST435
/usr/share/doc/perl-AppConfig-1.66/META.yml498
/usr/share/doc/perl-AppConfig-1.66/README29363
/usr/share/doc/perl-AppConfig-1.66/TODO2031
/usr/share/man/man3/AppConfig.3pm.gz11371
/usr/share/man/man3/AppConfig::Args.3pm.gz3229
/usr/share/man/man3/AppConfig::CGI.3pm.gz2694
/usr/share/man/man3/AppConfig::File.3pm.gz4803
/usr/share/man/man3/AppConfig::Getopt.3pm.gz2960
/usr/share/man/man3/AppConfig::State.3pm.gz7951
/usr/share/man/man3/AppConfig::Sys.3pm.gz2692
Component of
BuildrootStateUpdate?
centos5-rutgers-staging-build-3731-5777 expired yes
centos5-rutgers-staging-build-3730-5777 expired yes
centos5-rutgers-staging-build-3603-5735 expired yes
centos5-rutgers-staging-build-1917-3356 expired yes
centos5-rutgers-staging-build-1916-3356 expired yes
centos5-rutgers-staging-build-1915-3355 expired yes
centos5-rutgers-staging-build-1914-3355 expired yes
centos5-rutgers-staging-build-1898-3298 expired yes
centos5-rutgers-staging-build-1897-3293 expired yes
centos5-rutgers-staging-build-1896-3292 expired yes
centos5-rutgers-staging-build-1891-3281 expired yes
centos5-rutgers-build-752-956 expired yes
centos5-rutgers-build-751-956 expired yes
centos5-rutgers-build-750-954 expired yes
centos5-rutgers-build-749-954 expired yes
centos5-rutgers-build-604-775 expired yes
centos5-rutgers-build-603-773 expired yes
centos5-rutgers-build-521-654 expired yes
centos5-rutgers-build-509-642 expired yes
centos5-rutgers-build-508-642 expired yes
centos5-rutgers-build-353-453 expired yes
centos5-rutgers-build-351-453 expired yes
centos5-rutgers-build-346-449 expired yes
centos5-rutgers-build-86-62 expired yes
centos5-rutgers-build-85-62 expired yes
centos5-rutgers-build-74-52 expired yes
centos5-rutgers-build-73-52 expired yes
centos5-rutgers-build-72-52 expired yes