Fri, 03 Feb 2023 09:42:42 EST

Information for build perl-Package-DeprecationManager-0.11-1.ru6

ID3449
Package Nameperl-Package-DeprecationManager
Version0.11
Release1.ru6
Epoch
SummaryManage deprecation warnings for your distribution
DescriptionThis module allows you to manage a set of deprecations for one or more modules. When you import Package::DeprecationManager, you must provide a set of -deprecations as a hash ref. The keys are "feature" names, and the values are the version when that feature was deprecated.
Built byjmatth
State complete
StartedWed, 11 Feb 2015 14:13:05 EST
CompletedWed, 11 Feb 2015 14:16:12 EST
Taskbuild (centos6-rutgers-staging, perl-Package-DeprecationManager-0.11-1.ru6.src.rpm)
Tags
centos6-rutgers-staging
centos6-rutgers-testing
RPMs
src
perl-Package-DeprecationManager-0.11-1.ru6.src.rpm (info) (download)
noarch (build logs)
perl-Package-DeprecationManager-0.11-1.ru6.noarch.rpm (info) (download)
Changelog * Wed Feb 11 2015 Josh Matthews <jmatth@nbcs.rutgers.edu> 0.11-2 - Removing patch2 and adding Test::Requires * Mon Jun 20 2011 Paul Howarth <paul@city-fan.org> - 0.11-1 - Update to 0.11: - Allow an empty hash for the -deprecations parameter - BR: perl(ExtUtils::MakeMaker) - BR: perl(Test::CPAN::Changes) - BR: perl(Pod::Coverage::TrustPod) unconditionally - Update patches for old ExtUtils::MakeMaker and Test::More compatibility * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10-3 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild * Sat Jan 08 2011 Paul Howarth <paul@city-fan.org> - 0.10-2 - Update patches for old Test::More and no Test::Requires - perl(Pod::Coverage::TrustPod) now available everywhere except EPEL-4 * Sat Jan 08 2011 Iain Arnell <iarnell@gmail.com> - 0.10-1 - Update to 0.10: - Test suite uses Test::Fatal instead of Test::Exception * Mon Oct 18 2010 Paul Howarth <paul@city-fan.org> - 0.09-1 - Update to 0.09: - Added a compilation test * Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.08-1 - Update to 0.08: - The use of regular expressions in ignores didn't really work in 0.06 - Added missing deps on List::MoreUtils and Test::Requires - Replaced Test::Warn with Test::Output in the tests - Made the tests actually test what they should be testing - BR: Test::Output rather than Test::Warn - Update patches * Fri Oct 15 2010 Paul Howarth <paul@city-fan.org> - 0.06-1 - Update to 0.06: - Removed hard dep on Test::Warn for the benefit of Moose - Fixed what looked like a bug in -ignore handling - The -ignore parameter now accepts regexes as well as package names - Update compatibility patches - BR: List::MoreUtils - BR: Test::Requires where possible, patch it out elsewhere * Tue Jul 27 2010 Paul Howarth <paul@city-fan.org> - 0.04-2 - Clean up for Fedora submission * Mon Jul 26 2010 Paul Howarth <paul@city-fan.org> - 0.04-1 - Initial RPM version