Sun, 20 Sep 2020 02:29:16 EDT

Information for build awesome-3.4.11-1.ru6

ID2557
Package Nameawesome
Version3.4.11
Release1.ru6
Epoch
SummaryHighly configurable, framework window manager for X. Fast, light and extensible
DescriptionAwesome is a highly configurable, next generation framework window manager for X. It is very fast, light and extensible. It is primary targeted at power users, developers and any people dealing with every day computing tasks and want to have fine-grained control on its graphical environment.
Built bypquiza
State complete
StartedMon, 09 Jan 2012 11:09:07 EST
CompletedMon, 09 Jan 2012 11:15:53 EST
Taskbuild (centos6-rutgers-staging, awesome-3.4.11-1.ru6.src.rpm)
Tags
centos6-rutgers-staging
RPMs
src
awesome-3.4.11-1.ru6.src.rpm (info) (download)
i386 (build logs)
awesome-3.4.11-1.ru6.i386.rpm (info) (download)
awesome-doc-3.4.11-1.ru6.i386.rpm (info) (download)
awesome-debuginfo-3.4.11-1.ru6.i386.rpm (info) (download)
x86_64 (build logs)
awesome-3.4.11-1.ru6.x86_64.rpm (info) (download)
awesome-doc-3.4.11-1.ru6.x86_64.rpm (info) (download)
awesome-debuginfo-3.4.11-1.ru6.x86_64.rpm (info) (download)
Changelog * Tue Jan 03 2012 Phillip Quiza <pquiza@nbcs.rutgers.edu> - 3.4.11-1.ru6 - Initial build for Rutgers CentOS 6 - Added cairo-devel, imlib2, libxdg-basedir-devel, libev to BuildRequires * Mon Dec 05 2011 Thomas Moschny <thomas.moschny@gmx.de> - 3.4.11-1 - Update to 3.4.11, add patch for older Fedora releases. - Add dependencies on xterm and rlwrap. - Rework BR section. * Tue Sep 27 2011 Thomas Moschny <thomas.moschny@gmx.de> - 3.4.10-3 - Remove dependency on xsri. * Mon Sep 26 2011 Thomas Moschny <thomas.moschny@gmx.de> - 3.4.10-2 - Rebuilt for newer cairo rpm. * Sun May 22 2011 Thomas Moschny <thomas.moschny@gmx.de> - 3.4.10-1 - Update to 3.4.10. - Add dependencies to ease installation. * Mon Jan 17 2011 Michal Nowak <mnowak@redhat.com> 3.4.9-1 - 3.4.9 - require cmake >= 2.8.0 * Mon Oct 18 2010 Michal Nowak <mnowak@redhat.com> 3.4.8-1 - 3.4.8 * Thu Aug 26 2010 Michal Nowak <mnowak@redhat.com> 3.4.7-1 - 3.4.7 * Fri Jul 23 2010 Michal Nowak <mnowak@redhat.com> 3.4.6-1 - 3.4.6 * Mon May 17 2010 Michal Nowak <mnowak@redhat.com> 3.4.5-1 - 3.4.5 - we ship non-English man pages with this release * Thu Mar 04 2010 Michal Nowak <mnowak@redhat.com> 3.4.4-1 - 3.4.4 * Mon Jan 04 2010 Michal Nowak <mnowak@redhat.com> 3.4.3-1 - 3.4.3 - .in files are finally not installed anymore * Wed Dec 02 2009 Michal Nowak <mnowak@redhat.com> 3.4.2-1 - 3.4.2 - use xz instead of bz2 * Sun Nov 22 2009 Michal Nowak <mnowak@redhat.com> 3.4.1-1 - 3.4.1 * Thu Oct 22 2009 Michal Nowak <mnowak@redhat.com> 3.4-1 - 3.4 * Mon Oct 12 2009 Michal Nowak <mnowak@redhat.com> 3.4-0.3.rc3 - 3.4~rc3 * Tue Oct 06 2009 Michal Nowak <mnowak@redhat.com> 3.4-0.2.rc2 - remove .in files in build root rather in source dir * Mon Oct 05 2009 Michal Nowak <mnowak@redhat.com> 3.4-0.1.rc2 - 3.4-rc2 * Fri Sep 18 2009 Jens Petersen <petersen@redhat.com> - 3.3.4-3 - integrate rctag macro - simplify removal of .in files and filelist * Wed Sep 16 2009 Michal Nowak <mnowak@redhat.com> 3.3.4-2 - libxdg-basedir-devel as BR * Wed Sep 16 2009 Michal Nowak <mnowak@redhat.com> 3.3.4-1 - 3.3.4 - BuildRequire: ImageMagick, libxdg-basedir * Sat Aug 29 2009 Michal Nowak <mnowak@redhat.com> 3.3.3-1 - 3.3.3 * Sat Aug 01 2009 Michal Nowak <mnowak@redhat.com> 3.3.2-1 - 3.3.2 * Mon Jun 22 2009 Michal Nowak <mnowak@redhat.com> 3.3.1-1 - 3.3.1 * Fri Jun 12 2009 Michal Nowak <mnowak@redhat.com> 3.3-1 - 3.3 * Thu May 28 2009 Michal Nowak <mnowak@redhat.com> 3.3-0.4.rc4 - 3.3-rc4 * Tue May 19 2009 Michal Nowak <mnowak@redhat.com> 3.3-0.3.rc3 - 3.3-rc3 * Wed May 13 2009 Michal Nowak <mnowak@redhat.com> 3.3-0.2.rc2 - 3.3-rc2 * Thu May 07 2009 Michal Nowak <mnowak@redhat.com> 3.3-0.1.rc1 - 3.3-rc1 * Mon Mar 16 2009 Michal Nowak <mnowak@redhat.com> 3.2-1 - 3.2 * Mon Mar 02 2009 Michal Nowak <mnowak@redhat.com> 3.2-0.2.rc4 - 3.2-rc4 * Fri Feb 20 2009 Michal Nowak <mnowak@redhat.com> 3.2-0.1.rc3 - 3.2-rc3 - more docs files * Tue Jan 13 2009 Michal Nowak <mnowak@redhat.com> 3.1.1-1 - 3.1.1 * Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> 3.1-2 - minor SPEC-file changes * Sun Dec 14 2008 Michal Nowak <mnowak@redhat.com> 3.1-1 - 3.1 * Fri Sep 19 2008 Michal Nowak <mnowak@redhat.com> 3.0-1 - bump to 3.0 * Sat Sep 06 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.8.rc6 - bump to RC6 - /usr/share/awesome/themes/default is now, again, config file * Fri Aug 29 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.7.rc5 - bump to RC5 * Sun Aug 24 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.6.rc4 - bump to RC4 - rejecting awesome-3.0-rc3-enhance-wallpaper-cmd.patch -- solved upstream via awsetbg script - using imlib2 instead of GTK+ pixbuf * Mon Aug 18 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.5.rc3 - buildepend on readline-devel, glib2-devel, gtk2-devel, luadoc - install via "install -p" - %{_datadir}/%{name}/themes/default is not a config file no more, having config file in /usr is kinda weird - added sub-package awesome-doc to handle API doc files * Sat Aug 16 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.4.rc3 - awesome-3.0-rc3-enhance-wallpaper-cmd.patch: enhance setting of wallpaper - new dep: xsri - %{_datadir}/%{name}/themes/default is now handled configfile * Fri Aug 15 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.3.rc3 - bump to RC3 - xsession desktop file is now provided by upstream - dumped patches awesome-3.0-rc1-fedora-doc-path.patch awesome-3.0-rc2-fedora-xsession-path.patch both are now in upstream - cmake is now need >2.6 (present in rawhide) * Mon Aug 11 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.2.rc2 - bump to RC2 * Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> 3.0-0.1.rc1 - bump to awesome v3-the new generation * Mon Jul 28 2008 Michal Nowak <mnowak@redhat.com> 2.3.3-1 - version bump fixes two bugs - give floating dialogs of maximized windows focus - awesomerc: fix xterm -e in case of others terms * Thu Jul 17 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-7 - after some discussion I removed explicit dependency on libconfuse >= 2.6; the thing is that awesome runs fine with libconfuse-2.5 but does not build with < 2.6. Some build-time hack might be possible but I am obviously not going to be involved in this auto*magic. (thx Hans Ulrich Niedermann) * Wed Jul 16 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-6 - added libXinerama-devel, hopefully last BuildRequire * Wed Jul 16 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-5 - by mistake I removed BuildRequire on libconfuse-devel, now is back again (thanks Mamoru Tasaka) * Tue Jul 15 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-4 - small polishing in %doc line * Mon Jul 14 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-3 - removed redundant libconfuse-devel in BuildRequires - %{__install} .desktop file instead of install via desktop-file-install - changed the license to GPLv2+ - changes in .desktop file - updated --docdir to include %{version} too * Thu Jul 10 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-2 - bumped libconfuse BuildDependency to insist on version 2.6 - changed buildroot to not to have random one - enhanced %description * Thu Jul 03 2008 Michal Nowak <mnowak@redhat.com> 2.3.2-1 - version bump - add libconfuse-devel as a build dep. - removed Fedora as a vendor from .desktop file * Sun Jun 22 2008 Michal Nowak <mnowak@redhat.com> 2.3.1-1 - Initial package